Problema piklab ubuntu 11.10

Página 1 de 2. 1, 2  Siguiente

Ver el tema anterior Ver el tema siguiente Ir abajo

Problema piklab ubuntu 11.10

Mensaje por Locoelectronico el Mar 25 Oct 2011 - 4:58

Hola a todos,

He intentado instalar piklab en ubuntu 11.10 pero primero no esta en los repositorios, me descargue un .deb pero requiere una libreria kdelibs4c2a que ya no existe.

Quisiera saber si alguien me puede ayudar

Muchas gracias

Locoelectronico
Participante
Participante

Mensajes : 15
Fecha de inscripción : 25/09/2011

http://www.locoelectronico.zobyhost.com

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por Fernan el Mar 25 Oct 2011 - 10:31

Buenas

Tienes que bajarte varios deb de la pagina de ubuntu. El primero el kdelibs4c2a pero luego te seguira pidiendo otros tres o cuatro mas, esto es porque los deb de PIklab son bastante viejos y hacen mencion a ficheros que en la 11.10 ya no existen.

Prueba con este repositorio que esta algo mas actualizado que el piklab de ubuntu
deb http://ppa.launchpad.net/michael-gruz/elektronik/ubuntu maverick main
pero tambien te va a pedir instalar los debs. Con este lo he hecho yo y despues de instalar los deb que pide funciona perfectamente.

Fernan


Fernan
Participante Activo
Participante Activo

Mensajes : 38
Fecha de inscripción : 17/12/2008
Edad : 54
Localización : Bilbao

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por Locoelectronico el Dom 30 Oct 2011 - 22:02

Gracias fernan por tu colaboracion ya logre configurar el piklab en kubuntu 11.10

Ademas me atrevi a subir los paquetes necesarios para instalarlo es solo entrar a la carpeta por la terminal y das " sudo dpkg -i *deb " y listo,

Este es el encalce megaupload.com CA6KV5MS

Gracias

Locoelectronico
Participante
Participante

Mensajes : 15
Fecha de inscripción : 25/09/2011

http://www.locoelectronico.zobyhost.com

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por MichaelKnight el Dom 13 Nov 2011 - 14:15

Hola, he tratado de repetir tus pasos pero no me ha sido de ayuda. Yo tengo instalada la 11.10, pero en mi caso es de 64bits. Tratando de imitar lo ya visto, he bajado las librerias que se citaban pero en su version de 64bits, aunque sin exito. El problema es que continuamente me dice que hay problema de dependencias que no se pueden satisfacer y al final nada se instala o solo parte lo que necesito.

Si a este factor, añadimos que soy un novato puro y duro de linux, la cosa se complica ya que no tengo claro si son o no superables estas dependencias o si tendran algun efecto colateral si fuerzo algo.

Código:
michaelknight@ubuntu-sobremesa:~/Descargas/PIKLAB$ sudo dpkg -i *.deb
(Leyendo la base de datos ... 176580 ficheros o directorios instalados actualmente.)
Preparando para reemplazar kdelibs4c2a 4:3.5.10.dfsg.1-0lenny4 (usando kdelibs4c2a_3.5.10.dfsg.1-0lenny4_amd64.deb) ...
Desempaquetando el reemplazo de kdelibs4c2a ...
Preparando para reemplazar kdelibs-data 4:3.5.10.dfsg.1-5ubuntu2 (usando kdelibs-data_3.5.10.dfsg.1-5ubuntu2_all.deb) ...
Desempaquetando el reemplazo de kdelibs-data ...
Preparando para reemplazar libarts1c2a 1.5.9-2 (usando libarts1c2a_1.5.9-2_amd64.deb) ...
Desempaquetando el reemplazo de libarts1c2a ...
Preparando para reemplazar libartsc0-dev 1.5.9-3+b2 (usando libartsc0-dev_1.5.9-3+b2_amd64.deb) ...
Desempaquetando el reemplazo de libartsc0-dev ...
Preparando para reemplazar libavahi-qt3-1 0.6.23-3lenny3 (usando libavahi-qt3-1_0.6.23-3lenny3_amd64.deb) ...
Desempaquetando el reemplazo de libavahi-qt3-1 ...
Preparando para reemplazar piklab 0.15.9-1 (usando piklab_0.15.9-1_amd64.deb) ...
Desempaquetando el reemplazo de piklab ...
Configurando kdelibs-data (4:3.5.10.dfsg.1-5ubuntu2) ...
dpkg: problemas de dependencias impiden la configuración de libarts1c2a:
 libarts1c2a depende de libartsc0 (>= 1.5.9); sin embargo:
  El paquete `libartsc0' no está instalado.
 libarts1c2a depende de libaudiofile0 (>= 0.2.3-4); sin embargo:
  El paquete `libaudiofile0' no está instalado.
 libarts1c2a depende de libesd0 (>= 0.2.35) | libesd-alsa0 (>= 0.2.35); sin embargo:
  El paquete `libesd0' no está instalado.
  El paquete `libesd-alsa0' no está instalado.
 libarts1c2a depende de libjack0 (>= 0.109.2); sin embargo:
  El paquete `libjack0' no está instalado.
 libarts1c2a depende de oss-compat; sin embargo:
  El paquete `oss-compat' no está instalado.
dpkg: error al procesar libarts1c2a (--install):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libartsc0-dev:
 libartsc0-dev depende de libartsc0 (= 1.5.9-3+b2); sin embargo:
  El paquete `libartsc0' no está instalado.
 libartsc0-dev depende de libglib2.0-dev; sin embargo:
  El paquete `libglib2.0-dev' no está instalado.
dpkg: error al procesar libartsc0-dev (--install):
 problemas de dependencias - se deja sin configurar
Configurando libavahi-qt3-1 (0.6.23-3lenny3) ...
dpkg: problemas de dependencias impiden la configuración de kdelibs4c2a:
 kdelibs4c2a depende de libarts1c2a (>= 1.5.9); sin embargo:
 El paquete `libarts1c2a' no está configurado todavía.
dpkg: error al procesar kdelibs4c2a (--install):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de piklab:
 piklab depende de kdelibs4c2a (>= 4:3.5.9); sin embargo:
 El paquete `kdelibs4c2a' no está configurado todavía.
dpkg: error al procesar piklab (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para man-db ...
Procesando disparadores para desktop-file-utils ...
Procesando disparadores para gnome-menus ...
Procesando disparadores para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Procesando disparadores para menu ...
Procesando disparadores para shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'interface/x-winamp-skin'
Procesando disparadores para hicolor-icon-theme ...
Procesando disparadores para libc-bin ...
ldconfig deferred processing now taking place
Se encontraron errores al procesar:
 libarts1c2a
 libartsc0-dev
 kdelibs4c2a
 piklab

Esa es mi salida de consola por si puede servir de ayuda a los entendidos.
Espero vuestras sugerencias.
Saludos.

MichaelKnight
Participante
Participante

Mensajes : 17
Fecha de inscripción : 13/11/2011

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por MichaelKnight el Dom 13 Nov 2011 - 15:30

añado salida mediante apt-get

Código:
michaelknight@ubuntu-sobremesa:~$ sudo apt-get install piklab
Leyendo listas de paquetes... Hecho
Creando árbol de dependencias     
Leyendo la información de estado... Hecho
El paquete piklab no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente

E: El paquete «piklab» no tiene un candidato para la instalación
michaelknight@ubuntu-sobremesa:~$

MichaelKnight
Participante
Participante

Mensajes : 17
Fecha de inscripción : 13/11/2011

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por Locoelectronico el Dom 13 Nov 2011 - 20:25

MichaelKnight escribió:Hola, he tratado de repetir tus pasos pero no me ha sido de ayuda. Yo tengo instalada la 11.10, pero en mi caso es de 64bits. Tratando de imitar lo ya visto, he bajado las librerias que se citaban pero en su version de 64bits, aunque sin exito. El problema es que continuamente me dice que hay problema de dependencias que no se pueden satisfacer y al final nada se instala o solo parte lo que necesito.

Si a este factor, añadimos que soy un novato puro y duro de linux, la cosa se complica ya que no tengo claro si son o no superables estas dependencias o si tendran algun efecto colateral si fuerzo algo.

Código:
michaelknight@ubuntu-sobremesa:~/Descargas/PIKLAB$ sudo dpkg -i *.deb
(Leyendo la base de datos ... 176580 ficheros o directorios instalados actualmente.)
Preparando para reemplazar kdelibs4c2a 4:3.5.10.dfsg.1-0lenny4 (usando kdelibs4c2a_3.5.10.dfsg.1-0lenny4_amd64.deb) ...
Desempaquetando el reemplazo de kdelibs4c2a ...
Preparando para reemplazar kdelibs-data 4:3.5.10.dfsg.1-5ubuntu2 (usando kdelibs-data_3.5.10.dfsg.1-5ubuntu2_all.deb) ...
Desempaquetando el reemplazo de kdelibs-data ...
Preparando para reemplazar libarts1c2a 1.5.9-2 (usando libarts1c2a_1.5.9-2_amd64.deb) ...
Desempaquetando el reemplazo de libarts1c2a ...
Preparando para reemplazar libartsc0-dev 1.5.9-3+b2 (usando libartsc0-dev_1.5.9-3+b2_amd64.deb) ...
Desempaquetando el reemplazo de libartsc0-dev ...
Preparando para reemplazar libavahi-qt3-1 0.6.23-3lenny3 (usando libavahi-qt3-1_0.6.23-3lenny3_amd64.deb) ...
Desempaquetando el reemplazo de libavahi-qt3-1 ...
Preparando para reemplazar piklab 0.15.9-1 (usando piklab_0.15.9-1_amd64.deb) ...
Desempaquetando el reemplazo de piklab ...
Configurando kdelibs-data (4:3.5.10.dfsg.1-5ubuntu2) ...
dpkg: problemas de dependencias impiden la configuración de libarts1c2a:
 libarts1c2a depende de libartsc0 (>= 1.5.9); sin embargo:
  El paquete `libartsc0' no está instalado.
 libarts1c2a depende de libaudiofile0 (>= 0.2.3-4); sin embargo:
  El paquete `libaudiofile0' no está instalado.
 libarts1c2a depende de libesd0 (>= 0.2.35) | libesd-alsa0 (>= 0.2.35); sin embargo:
  El paquete `libesd0' no está instalado.
  El paquete `libesd-alsa0' no está instalado.
 libarts1c2a depende de libjack0 (>= 0.109.2); sin embargo:
  El paquete `libjack0' no está instalado.
 libarts1c2a depende de oss-compat; sin embargo:
  El paquete `oss-compat' no está instalado.
dpkg: error al procesar libarts1c2a (--install):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libartsc0-dev:
 libartsc0-dev depende de libartsc0 (= 1.5.9-3+b2); sin embargo:
  El paquete `libartsc0' no está instalado.
 libartsc0-dev depende de libglib2.0-dev; sin embargo:
  El paquete `libglib2.0-dev' no está instalado.
dpkg: error al procesar libartsc0-dev (--install):
 problemas de dependencias - se deja sin configurar
Configurando libavahi-qt3-1 (0.6.23-3lenny3) ...
dpkg: problemas de dependencias impiden la configuración de kdelibs4c2a:
 kdelibs4c2a depende de libarts1c2a (>= 1.5.9); sin embargo:
 El paquete `libarts1c2a' no está configurado todavía.
dpkg: error al procesar kdelibs4c2a (--install):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de piklab:
 piklab depende de kdelibs4c2a (>= 4:3.5.9); sin embargo:
 El paquete `kdelibs4c2a' no está configurado todavía.
dpkg: error al procesar piklab (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para man-db ...
Procesando disparadores para desktop-file-utils ...
Procesando disparadores para gnome-menus ...
Procesando disparadores para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Procesando disparadores para menu ...
Procesando disparadores para shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'interface/x-winamp-skin'
Procesando disparadores para hicolor-icon-theme ...
Procesando disparadores para libc-bin ...
ldconfig deferred processing now taking place
Se encontraron errores al procesar:
 libarts1c2a
 libartsc0-dev
 kdelibs4c2a
 piklab

Esa es mi salida de consola por si puede servir de ayuda a los entendidos.
Espero vuestras sugerencias.
Saludos.



Bueno Creo que por tu OS ser de 64bits necesitas otros paquetes adicionales que son
libaudiofile0
libesd0
libjack0
oss-compat

Ademas la libreria libartsc0-dev no es necesario necesitas libartsc0 sola sin el "-dev"

Locoelectronico
Participante
Participante

Mensajes : 15
Fecha de inscripción : 25/09/2011

http://www.locoelectronico.zobyhost.com

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por MichaelKnight el Dom 13 Nov 2011 - 20:49

Hola, ante todo, gracias por responder tan rapido.

He seguido tus indicaciones y esto es lo que ha ocurrido:

Código:
root@ubuntu-sobremesa:~/Descargas/PIKLAB# apt-get install libartsc0
Leyendo listas de paquetes... Hecho
Creando árbol de dependencias     
Leyendo la información de estado... Hecho
El paquete libartsc0 no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente

E: El paquete «libartsc0» no tiene un candidato para la instalación

estaba claro que faltando aun un paquete por instalar no iba a poder lanzar piklab, pero aun asi:

Código:
root@ubuntu-sobremesa:~/Descargas/PIKLAB# dpkg -i piklab_0.15.9-1_amd64.deb
Seleccionando el paquete piklab previamente no seleccionado.
(Leyendo la base de datos ... 179290 ficheros o directorios instalados actualmente.)
Desempaquetando piklab (de piklab_0.15.9-1_amd64.deb) ...
dpkg: problemas de dependencias impiden la configuración de piklab:
 piklab depende de kdelibs4c2a (>= 4:3.5.9); sin embargo:
  El paquete `kdelibs4c2a' no está instalado.
dpkg: error al procesar piklab (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para menu ...
Procesando disparadores para man-db ...
Procesando disparadores para desktop-file-utils ...
Procesando disparadores para gnome-menus ...
Procesando disparadores para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Procesando disparadores para shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'interface/x-winamp-skin'
Procesando disparadores para hicolor-icon-theme ...
Se encontraron errores al procesar:
 piklab

Pese a esto me crea un acceso directo en la seccion de Desarrollo del menu de ubuntu, pero logicamente no ejecuta nada.

Estando como estamos tan cerca, ¿que me falta para resolver estas dependencias?

saludos y gracias nuevamente

MichaelKnight
Participante
Participante

Mensajes : 17
Fecha de inscripción : 13/11/2011

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por MichaelKnight el Dom 13 Nov 2011 - 20:57

Aprovecho para decir, aunque no se si afectara en algo, que estoy usando unity como escritorio.

MichaelKnight
Participante
Participante

Mensajes : 17
Fecha de inscripción : 13/11/2011

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por Locoelectronico el Lun 14 Nov 2011 - 2:32

MichaelKnight escribió:Hola, ante todo, gracias por responder tan rapido.

He seguido tus indicaciones y esto es lo que ha ocurrido:

Código:
root@ubuntu-sobremesa:~/Descargas/PIKLAB# apt-get install libartsc0
Leyendo listas de paquetes... Hecho
Creando árbol de dependencias     
Leyendo la información de estado... Hecho
El paquete libartsc0 no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente

E: El paquete «libartsc0» no tiene un candidato para la instalación




estaba claro que faltando aun un paquete por instalar no iba a poder lanzar piklab, pero aun asi:

Código:
root@ubuntu-sobremesa:~/Descargas/PIKLAB# dpkg -i piklab_0.15.9-1_amd64.deb
Seleccionando el paquete piklab previamente no seleccionado.
(Leyendo la base de datos ... 179290 ficheros o directorios instalados actualmente.)
Desempaquetando piklab (de piklab_0.15.9-1_amd64.deb) ...
dpkg: problemas de dependencias impiden la configuración de piklab:
 piklab depende de kdelibs4c2a (>= 4:3.5.9); sin embargo:
  El paquete `kdelibs4c2a' no está instalado.
dpkg: error al procesar piklab (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para menu ...
Procesando disparadores para man-db ...
Procesando disparadores para desktop-file-utils ...
Procesando disparadores para gnome-menus ...
Procesando disparadores para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Procesando disparadores para shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'interface/x-winamp-skin'
Procesando disparadores para hicolor-icon-theme ...
Se encontraron errores al procesar:
 piklab

Pese a esto me crea un acceso directo en la seccion de Desarrollo del menu de ubuntu, pero logicamente no ejecuta nada.

Estando como estamos tan cerca, ¿que me falta para resolver estas dependencias?

saludos y gracias nuevamente

Aqui tienes el paquete que te falta descargalo y lo guardas en la carpeta de donde estas haciendo la instalacion.

Ademas te recomiendo antes de instalar hacer: "sudo apt-get -f install" para que limpies todos los errores de la intalacion y empezar de cero, no es obligacion pero puee funcionar mejor.

http://ftp.mx.debian.org/debian/pool/main/a/arts/libartsc0_1.5.9-2_amd64.deb

Locoelectronico
Participante
Participante

Mensajes : 15
Fecha de inscripción : 25/09/2011

http://www.locoelectronico.zobyhost.com

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por MichaelKnight el Lun 14 Nov 2011 - 12:06

Gracias de nuevo por el interes que estas tomandote por mi problema.

Tal y como me has dicho he instalado ese paquete sin problema alguno, pero en cambio al instalar piklab vuelven a salir errores

Código:
michaelknight@ubuntu-sobremesa:~/Descargas/PIKLAB$ sudo dpkg -i piklab_0.15.9-1_amd64.deb
Seleccionando el paquete piklab previamente no seleccionado.
(Leyendo la base de datos ... 179295 ficheros o directorios instalados actualmente.)
Desempaquetando piklab (de piklab_0.15.9-1_amd64.deb) ...
dpkg: problemas de dependencias impiden la configuración de piklab:
 piklab depende de kdelibs4c2a (>= 4:3.5.9); sin embargo:
  El paquete `kdelibs4c2a' no está instalado.
dpkg: error al procesar piklab (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para menu ...
Procesando disparadores para man-db ...
Procesando disparadores para desktop-file-utils ...
Procesando disparadores para gnome-menus ...
Procesando disparadores para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Procesando disparadores para shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'interface/x-winamp-skin'
Procesando disparadores para hicolor-icon-theme ...
Se encontraron errores al procesar:
 piklab

Trato de instalar el paquete he descargado y me dice esto otro:

Código:
michaelknight@ubuntu-sobremesa:~/Descargas/PIKLAB$ sudo dpkg -i kdelibs4c2a_3.5.10.dfsg.1-0lenny4_amd64.deb
(Leyendo la base de datos ... 178306 ficheros o directorios instalados actualmente.)
Preparando para reemplazar kdelibs4c2a 4:3.5.10.dfsg.1-0lenny4 (usando kdelibs4c2a_3.5.10.dfsg.1-0lenny4_amd64.deb) ...
Desempaquetando el reemplazo de kdelibs4c2a ...
dpkg: problemas de dependencias impiden la configuración de kdelibs4c2a:
 kdelibs4c2a depende de libarts1c2a (>= 1.5.9); sin embargo:
  El paquete `libarts1c2a' no está instalado.
 kdelibs4c2a depende de libkrb53 (>= 1.6.dfsg.2); sin embargo:
  El paquete `libkrb53' no está instalado.
 kdelibs4c2a depende de menu-xdg; sin embargo:
  El paquete `menu-xdg' no está instalado.
dpkg: error al procesar kdelibs4c2a (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para man-db ...
Se encontraron errores al procesar:
 kdelibs4c2a

Cuando trato de instalar cualquier otro paquete que depende de otro, me salen nuevas dependencias que no se pueden satisfacer y asi continuamente. ¿que hago mal?

MichaelKnight
Participante
Participante

Mensajes : 17
Fecha de inscripción : 13/11/2011

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por Locoelectronico el Lun 14 Nov 2011 - 12:46

bueno creo que debes buscar y descargar todas las dependencias que te pide de la pagina de ubuntu http://packages.ubuntu.com/ y guardarlas todas en tu carpeta de instalacion en tu caso "~/Descargas/PIKLAB" y ejecutar "sudo dpkg -i *deb". El problema es que Piklab esta desarrollado sobre KDE y tu usas Gnome debes instalar muchas librerias de KDE.

De todas formas dale que si otros pudieron tu tambien y no temas pregutar.

Locoelectronico
Participante
Participante

Mensajes : 15
Fecha de inscripción : 25/09/2011

http://www.locoelectronico.zobyhost.com

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por MichaelKnight el Lun 14 Nov 2011 - 13:17

Gracias por tus animos!

A ver, fui descargando esos paquetes pero cuando voy a instalarlos me dicen que no se pueden instalar. Seguire probando e ire comentando mis progresos para que puedan servir tambien a otros.

Aprovecho para comentar que estoy tratando tambien de echar a andar el MPLAB X que esta hecho en java, de hecho es una modificacion del netbeans pero es una beta que esta dando algunas complicaciones. A mi por ejemplo no me encuentra ningun compilador de los que tengo instalados.

MichaelKnight
Participante
Participante

Mensajes : 17
Fecha de inscripción : 13/11/2011

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por MichaelKnight el Mar 15 Nov 2011 - 1:10

Cada vez me siento mas inutil de verdad.....

A ver, esta es la lista de dependencias:

Código:
Los siguientes paquetes tienen dependencias incumplidas:

piklab: Depends: kdelibs4c2a (>= 4:3.5.9) pero no va a ser instalado
        Depends: libc6 (>= 2.7) pero 2.13-20ubuntu5 no está instalado
        Depends: libqt3-mt (>= 3:3.3.8-b) pero 3:3.3.8-b-8ubuntu1 no está instalado
        Depends: libreadline6 (>= 6.0) pero 6.2-2ubuntu1 no está instalado
        Depends: libstdc++6 (>= 4.4.0) pero 4.6.1-9ubuntu3 no está instalado
        Depends: libusb-0.1-4 (>= 2:0.1.12) pero 2:0.1.12-18 no está instalado

Bueno, harto de descargar paquetes y que me digan continuamente que "depende de tal o cual pero no va a ser instalado" por mas que miro en psynaptic parecen estar todos pero no se ni como ni por que no valen. Ejemplo:
Depends: libc6 (>= 2.7) pero 2.13-20ubuntu5 no está instalado

Y asi con todas las demas. Resulta que estan, pero por alguna razon no estan siendo validas. ¿Puede que necesite instalar las de 32bits? En tal caso, cuando digo de poner estas ultimas me pide quitar multitud de paquetes; supongo que luego instalara de nuevo los mismos pero en version 32bits, aunque no he querido arriesgar dado que no se si iba a liarla.

En fin, siento ser tan sumamente pesado pero me gustaria conseguir que funcione para poder seguir programando los pic's sin tener que volver a Windows. Ya que he dado este paso me gustaria no tener que dar marcha atras.

Saludos y gracias por adelantado.


MichaelKnight
Participante
Participante

Mensajes : 17
Fecha de inscripción : 13/11/2011

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por Locoelectronico el Mar 15 Nov 2011 - 1:27

bueno creo que tambien te falta instalar el algunos paquetes basicos de compilacion
"sudo apt-get install build-essential" eso te ahorrara descargar algunos paquetes
de todas formas hechate un vistaso a este link:

http://ubuntulife.wordpress.com/2010/10/20/cosas-a-hacer-despues-de-instalar-ubuntu-10-10-maverick-meerkat-2/
Hay varias cosas que te pueden servir no solo para piklab

Locoelectronico
Participante
Participante

Mensajes : 15
Fecha de inscripción : 25/09/2011

http://www.locoelectronico.zobyhost.com

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por MichaelKnight el Mar 15 Nov 2011 - 11:38

Gracias por tu paciencia. El build-essential es algo que he instalado y desinstalado reiteradas veces. Ahora esta instalado y cuando trato instalar PIKLAB desde el repostorio agregado a los origenes del software de ubuntu tengo este mensaje desde el Centro de software de Ubuntu:

Código:
Los siguientes paquetes tienen dependencias incumplidas:

piklab: Depends: kdelibs4c2a (>= 4:3.5.9) pero no va a ser instalado
        Depends: libc6 (>= 2.7) pero 2.13-20ubuntu5 no está instalado
        Depends: libqt3-mt (>= 3:3.3.8-b) pero 3:3.3.8-b-8ubuntu1 no está instalado
        Depends: libreadline6 (>= 6.0) pero 6.2-2ubuntu1 no está instalado
        Depends: libstdc++6 (>= 4.4.0) pero 4.6.1-9ubuntu3 no está instalado
        Depends: libusb-0.1-4 (>= 2:0.1.12) pero 2:0.1.12-18 no está instalado

y este otro desde consola

Código:


michaelknight@ubuntu-sobremesa:~$ sudo apt-get install piklab
Leyendo listas de paquetes... Hecho
Creando árbol de dependencias     
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 piklab : Depende de: kdelibs4c2a (>= 4:3.5.9) pero no es instalable
E: No se han podido corregir los problemas; ha retenido paquetes rotos.

En caso de hacerlo desde el propio paquete de instalacion que me baje:

Código:


michaelknight@ubuntu-sobremesa:~/Descargas/PIKLAB$ sudo dpkg -i piklab_0.15.9-1_amd64.deb
(Leyendo la base de datos ... 177133 ficheros o directorios instalados actualmente.)
Preparando para reemplazar piklab 0.15.9-1 (usando piklab_0.15.9-1_amd64.deb) ...
Desempaquetando el reemplazo de piklab ...
dpkg: problemas de dependencias impiden la configuración de piklab:
 piklab depende de kdelibs4c2a (>= 4:3.5.9); sin embargo:
  El paquete `kdelibs4c2a' no está instalado.
dpkg: error al procesar piklab (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para menu ...
Procesando disparadores para man-db ...
Procesando disparadores para desktop-file-utils ...
Procesando disparadores para gnome-menus ...
Procesando disparadores para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Procesando disparadores para shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'interface/x-winamp-skin'
Procesando disparadores para hicolor-icon-theme ...
Se encontraron errores al procesar:
 piklab

Si volvemos a tratar de instalar el paquete de kde que menciona desde repositorio:

Código:
michaelknight@ubuntu-sobremesa:~/Descargas/PIKLAB$ sudo apt-get install kdelibs4c2a
Leyendo listas de paquetes... Hecho
Creando árbol de dependencias     
Leyendo la información de estado... Hecho
El paquete kdelibs4c2a no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente

E: El paquete «kdelibs4c2a» no tiene un candidato para la instalación

y cuando trato de instalar el paquete que baje:

Código:
michaelknight@ubuntu-sobremesa:~/Descargas/PIKLAB$ sudo dpkg -i kdelibs4c2a_3.5.10.dfsg.1-0lenny4_amd64.deb
Seleccionando el paquete kdelibs4c2a previamente no seleccionado.
(Leyendo la base de datos ... 177041 ficheros o directorios instalados actualmente.)
Desempaquetando kdelibs4c2a (de kdelibs4c2a_3.5.10.dfsg.1-0lenny4_amd64.deb) ...
dpkg: problemas de dependencias impiden la configuración de kdelibs4c2a:
 kdelibs4c2a depende de libart-2.0-2 (>= 2.3.18); sin embargo:
  El paquete `libart-2.0-2' no está instalado.
 kdelibs4c2a depende de libarts1c2a (>= 1.5.9); sin embargo:
  El paquete `libarts1c2a' no está instalado.
 kdelibs4c2a depende de libavahi-qt3-1 (>= 0.6.16); sin embargo:
  El paquete `libavahi-qt3-1' no está instalado.
 kdelibs4c2a depende de libkrb53 (>= 1.6.dfsg.2); sin embargo:
  El paquete `libkrb53' no está instalado.
 kdelibs4c2a depende de menu-xdg; sin embargo:
  El paquete `menu-xdg' no está instalado.
dpkg: error al procesar kdelibs4c2a (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para man-db ...
Se encontraron errores al procesar:
 kdelibs4c2a

Verdaderamente esta siendo un martirio y esto de ser un novato se hace cuesta arriba.

MichaelKnight
Participante
Participante

Mensajes : 17
Fecha de inscripción : 13/11/2011

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por Locoelectronico el Mar 15 Nov 2011 - 12:54

descarga todos los debs que te pide y los guardas en una carpeta junto con piklab y los otros que ya has descargado manualmente y ejecutas "sudo dpkg -i *deb"

Locoelectronico
Participante
Participante

Mensajes : 15
Fecha de inscripción : 25/09/2011

http://www.locoelectronico.zobyhost.com

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por MichaelKnight el Mar 15 Nov 2011 - 13:42

Bueno, pues tras mucho sufrimiento consegui echar a andar el PIKLAB con la sorpresa de que no es compatible con mi version de firmware de pic kit2, asi que tendre que hacerle downgrade confiando en que a posteriori no me haga falta una version superior de cara a utilizar determinados modelos.

Saludos y gracias por tu paciencia y ayuda.

MichaelKnight
Participante
Participante

Mensajes : 17
Fecha de inscripción : 13/11/2011

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por Locoelectronico el Mar 15 Nov 2011 - 14:25

Si lo logras me cuentas porque yo todavía no he podido configurarlo para grabar los PIC lo hago con pk2cmd

Locoelectronico
Participante
Participante

Mensajes : 15
Fecha de inscripción : 25/09/2011

http://www.locoelectronico.zobyhost.com

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por MichaelKnight el Mar 15 Nov 2011 - 14:37

no pondria la mano en el fuego, pero bueno, lo intentare. Mi esperanza es que usando la sintaxis de consola para pk2-cmd pudiera conseguir algo.

La otra opcion seria recurrir a la consola para programar haciendome algun script, pero eso es perder una funcionalidad importante en cuanto a comodidad del IDE.

Tambien estoy ahora tratando de poner el pikdev a ver que tal. Nuevamente me salen problemas de dependencias de KDE, pero confio en solucionarlas sin molestar a nadie esta vez.

MichaelKnight
Participante
Participante

Mensajes : 17
Fecha de inscripción : 13/11/2011

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por Locoelectronico el Mar 15 Nov 2011 - 17:31

Y tu que lenguaje usas para programar tus pics?

Locoelectronico
Participante
Participante

Mensajes : 15
Fecha de inscripción : 25/09/2011

http://www.locoelectronico.zobyhost.com

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por MichaelKnight el Mar 15 Nov 2011 - 18:42

Siempre he utilizado C por su simplicidad, al menos para mi es mas comodo.

Cuando lo he estado haciendo en windows usaba CCS, pero ahora en ubuntu tengo que ver que IDE utilizar y que compilador. A pirori si el SDCC esta preparado para los modelos que vaya necesitando supongo que no tendre que buscar mucho mas.

No obstante, en la web de microchip tambien tienen otros compiladores con versiones gratis (no se la diferencia con las de pago) y un entorno basado en NetBeans llamado MPLAB X que es bastante prometedor y que apuesto a que acabara siendo mi entorno habitual cuando deje de ser beta. Cuando lo he probado me ha dado varios problemas y ahora que actualice a java 1.7 directamente no funciona, es un bug reportado en su foro. Ojala este listo en breve.

MichaelKnight
Participante
Participante

Mensajes : 17
Fecha de inscripción : 13/11/2011

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por Locoelectronico el Mar 15 Nov 2011 - 19:08

Pues te tengo una buena noticia si instalas CCS con wine, Piklab te lo reconoce perfecto solo vas a "Settings - Configurar compiladores" y lo buscas, apenas lo seleccionas te lo reconoce automaticamente

Locoelectronico
Participante
Participante

Mensajes : 15
Fecha de inscripción : 25/09/2011

http://www.locoelectronico.zobyhost.com

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por MichaelKnight el Mar 15 Nov 2011 - 19:24

Imagino que en realidad ni lo necesitaria instalar con wine. Si copio el directorio que contiene el compilador en la instalacion que hice en su dia en Windows a un directorio de mi ordenador con ubuntu bastaria, ¿no?

MichaelKnight
Participante
Participante

Mensajes : 17
Fecha de inscripción : 13/11/2011

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por Locoelectronico el Mar 15 Nov 2011 - 19:39

La verdad no lo he intentado pero yo lo instale con wine y me anda full, ademas no es dificil la instalacion

Locoelectronico
Participante
Participante

Mensajes : 15
Fecha de inscripción : 25/09/2011

http://www.locoelectronico.zobyhost.com

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por MichaelKnight el Mar 15 Nov 2011 - 20:39

Confirmo que no has ni de instalarlo, con copiar la carpeta que contiene el compilador del CCS te sobra y basta. Esto es una muy buena noticia porque me garantiza que voy a trabajar con un compilador 100% fiable.

MichaelKnight
Participante
Participante

Mensajes : 17
Fecha de inscripción : 13/11/2011

Volver arriba Ir abajo

Re: Problema piklab ubuntu 11.10

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Página 1 de 2. 1, 2  Siguiente

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.