Problema entre modulo PWM y TMR0

Ver el tema anterior Ver el tema siguiente Ir abajo

Problema entre modulo PWM y TMR0

Mensaje por Invitado el Dom 25 Mayo 2014 - 15:31

Hola a todos.

Estoy haciendo un coche que se controla por el mando a distancia de la TV. Para detectar los códigos uso tiempos controlados por TMR0, todo bien.

Ahora activo el modulo PWM que trabaja internamente con el timer1 y automaticamente deja de funcionar la recepción de los codigos del mando de la TV.

He probado los dos conceptos por separado; la recepción de código funciona al 100% y el modulo PWM tambien, pero me he encontrado que al integrarlos los dos en el mismo proyecto me deja de funcional lo relacionado con el TMR0 ???????????

No le encuentro sentido, ya que van por timers diferentes.

El el micro es un PIC16F88 y el compilador que estoy usando en MikroC.

Alguna pista?

Gracias.

Invitado
Invitado


Volver arriba Ir abajo

Re: Problema entre modulo PWM y TMR0

Mensaje por Invitado el Mar 27 Mayo 2014 - 8:15

Hola.

Bueno; ya descubrí el pastel:

La libreria PWM de MikroC, utiliza delays que trabajan con el TMR0, de ahi viene que justo al activar el modulo PWM, deje de funcionar la recepción de mis códigos ya que esta recepción utiliza el TMR0.

Conclusión: Tego que hacer yo el PWM a palo seco, pasando de la libreria.

Saludos.

Invitado
Invitado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.